Configuration Examples for Configuring EtherChannels
Configuration Examples for Configuring EtherChannels
Configuring Layer 2 EtherChannels: Examples
This example shows how to configure an EtherChannel on a single switch in the stack. It assigns two ports
as static-access ports in VLAN 10 to channel 5 with the PAgP mode desirable:
Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode desirable non-silent
Switch(config-if-range)# end
This example shows how to configure an EtherChannel on a single switch in the stack. It assigns two ports
as static-access ports in VLAN 10 to channel 5 with the LACP mode active:
Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode active
Switch(config-if-range)# end
This example shows how to configure a cross-stack EtherChannel. It uses LACP passive mode and assigns
two ports on stack member 1 and one port on stack member 2 as static-access ports in VLAN 10 to channel
5:
Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/4 -5
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode passive
Switch(config-if-range)# exit
Switch(config)# interface gigabitethernet3/0/3
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10
Switch(config-if)# channel-group 5 mode passive
Switch(config-if)# exit
Configuring Port-Channel Logical Interfaces: Example
This example shows how to create the logical port channel 5 and assign 172.10.20.10 as its IP address:
Switch# configure terminal
Switch(config)# interface port-channel 5
Switch(config-if)# no switchport
Switch(config-if)# ip address 172.10.20.10 255.255.255.0
Switch(config-if)# end
Catalyst 2960-XR Switch Layer 2 Configuration Guide, Cisco IOS Release 15.0(2)EX1
136
Configuring EtherChannels
OL-29424-01